Yamaha Triples
Search Forums | Statistics | User Listing Forums | Calendar | Albums | Chat | Skins | Language
You are logged in as a guest. ( logon | register )


Electronic ignition clicking. Won't kick start. Fuses good. Possible ignition module?
Moderators: Moderators

View previous thread :: View next thread
   Maintenance and Repair -> IgnitionMessage format
 
MauiYamahaXS750
Posted 2018-02-16 3:53 PM (#153607)
Subject: Electronic ignition clicking. Won't kick start. Fuses good. Possible ignition module?



Member

Posts: 13

Location: Maui, Hawaii
My battery died so I put it on the charger. I mistakenly put it on 6v boost charge instead on 12v trickle charge. With the charger still connected I pushed the electronic starter, kinda cranked for a second then heard a small pop and now when I press the starter it only clicks. I tried kick starting it a few times with no luck and now the kick start feels like it's locked and I can't even kick it down. Checked all my fuses and they are all good. I called a mechanic and he said it might be the ignition module but can't be sure because he hasn't seen the bike. Please help!

Bike is an 1978 XS 750 Special

The worst part about this whole situation is that I've been trying to sell the bike for awhile and I was actually about to sell it when this happen. I mean he was holding they money out for me and when I went to start the bike one final time thinking it was charged and ready to go, this happened and needless to say he didn't buy it.

Edited by MauiYamahaXS750 2018-02-16 3:54 PM
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

 

Running MegaBBS ASP Forum Software
© 2002-2018 PD9 Software
(Delete all cookies set by this site)